Contact Me

As with any tech geek there are many ways to contact me.  Try any one (or all if you are very serious) of the following outlets to get in touch with me.  If all else fails, turn on the bat light :)

 

  • Nagaraj Narayan

    Hi Guys,

    I’m sitting for my VCP on Nov 19, I’m unable to download a copy of vsphere 5.0 vcenter, vcenter server appliance and other components. Please let me know if I could still get a copy somewhere.
    Thanks in advance

    Naga

  • mwpreston

    Hi! Thanks for the comment, no, you can just write the 5.0 certification providing you have taken the appropriate qualifying course!

  • Ron

    Hey man.. great work!
    i am getting a error (vpxd) on the power up script…
    I am running VC5.0, ESXi5.0U2

    I have manually powered up the VC and host in the cluster however i am getting this error????
    …Get-Service : Cannot find any service with service name ‘vpxd’.
    At E:powerCLIpowerdownupzpowerup.ps1:47 char:24
    + while ((Get-Service <<<< vpxd).Status -ne "Running")
    + CategoryInfo : ObjectNotFound: (vpxd:String) [Get-Service], ServiceCommandException
    + FullyQualifiedErrorId : NoServiceFoundForGivenName,Microsoft.PowerShell.Commands.GetServiceCommand

    Any ideas?
    Also can we add a popup box for the VC, userID and userpassword?
    something like this –

    # Login Credentials
    $vccred = $Host.UI.PromptForCredential("The Virtual Environment @vTwindude", "vCenter Credentials", "administrator", "")
    $vc = Read-Host -Prompt "What is your vCenter IP Address?"
    Connect-VIServer $vc -Credential $vccred

  • vgianni

    Hi ,
    great post , fantastic for reading , especially for the Vcap5 , one question i have if you know , i want to create additional admin users to the VMA ( along side with vi-admin) , does anybody know how to do it ?
    I mean to actually create the user and the add it to the same group vi-admin is .

    Regards

  • vmware vs

    Hi,

    I have SSO, Inventory service and vCenter installed on separate machines. I need to upgrade then from 5.1 U1 to 5.5 U1 but I like to have all three components installed on my vCenter server during upgrade.

    I tried installing SSO 5.5 on my vCenter server but for obvious reasons it did not detect previous version of SSO installed on same server as it is running on a separate machine and therefore it just installed SSO on it as fresh install and same for Inventory service.

    How could I achieve this upgrade and have them running on a single machine which would be vCenter server VM.

    I tried this approach :-

    take full backup of db

    backup ssl :- C:ProgramDataVMwareVMware VirtualCenterSSL

    Back up your existing SSO DB – kb.vmware.com/kb/2034928

    Install SSO 5.1 on the current vCenter server

    Restore the backed up SSO DB to your new instance
    SSO got successfully installed, when i tried installing inventory server service on my vcenter server, installation is failing with error

    “[2014-09-04 06:27:21,912 main ERROR com.vmware.vim.install.impl.RegistrationProviderImpl] Unable to connect to server

    [2014-09-04 06:27:21,912 main DEBUG com.vmware.vim.install.impl.RegistrationProviderImpl]

    java.net.ConnectException: Connection refused: connect

    at java.net.PlainSocketImpl.socketConnect(Native Method)

    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)

    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)

    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)

    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

    at java.net.Socket.connect(Socket.java:529)

    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:564)

    at com.vmware.vim.install.impl.RegistrationProviderImpl.getSslCertificates(RegistrationProviderImpl.java:312)

    at com.vmware.vim.install.impl.RegistrationProviderImpl.initialize(RegistrationProviderImpl.java:236)

    at com.vmware.vim.install.impl.RegistrationProviderImpl.(RegistrationProviderImpl.java:133)

    at com.vmware.vim.install.RegistrationProviderFactory.getRegistrationProvider(RegistrationProviderFactory.java:143)

    at com.vmware.vim.install.RegistrationProviderFactory.getRegistrationProvider(RegistrationProviderFactory.java:60)

    at com.vmware.vim.install.cli.commands.CommandArgumentsParser.createServiceProvider(CommandArgumentsParser.java:253)

    at com.vmware.vim.install.cli.commands.CommandArgumentsParser.parseCommand(CommandArgumentsParser.java:99)

    at com.vmware.vim.install.cli.commands.CommandFactory.createValidateLsCommand(CommandFactory.java:36)

    at com.vmware.vim.install.cli.RegTool.process(RegTool.java:86)

    at com.vmware.vim.install.cli.RegTool.main(RegTool.java:33)

    [2014-09-04 06:27:21,944 main ERROR com.vmware.vim.install.cli.commands.CommandArgumentsParser] Unable to connect to server

    [2014-09-04 06:27:21,944 main INFO com.vmware.vim.install.cli.RegTool] Return code is: ServiceNotResponding

    It is looking at SSL certificate of old sso server. how should i resolve this?

    thanks

    • mwpreston

      This is really a tough one! How big is your environment?

      I would most likely consider a fresh install of vCenter with the components at this point. I’m not sure how to consolidate these services and if it was me, I’d probably just recreate my vCenter as it will more than likely be faster in the long run.

      Thanks for reaching out

      • vmware vs

        Hi,
        Thanks for your reply. We have 100 plus hosts with 1200 VMs running on them in multiple clusters and have vco, HP insight are integrated with vcenter.
        I think you are right that way would be easier and clean to perform.

        Thanks,